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Quick Start Guide  

Introduction 

The Lab.gruppen D Series Plugin for QSC® Q-SYS™ Designer software makes it is easy to integrate 
D Series and PLM+ Series amplifiers into any Q-SYS project. It allows for control and monitoring of 
multiple functions.  

Plugin Compatibility  

Hence the name, D Series, this version supports all D Series Lake (D10:4L, D20:4L, D40:4L, D80:4L, 
D120:4L and D200:4L) and all PLM+ Series (PLM5K44, PLM12K44 and PLM20K44) amplifiers.  
 
Lake Controller 
The Plugin can run at the same time as an online Lake Controller is connected and also 
controlling/monitoring the same amplifier. Any changes done in Lake Controller will sync back to Q-
SYS and vice versa.   
 
Q-SYS Core Requirements 
Plugins use the Q-SYS Scripting Engine, which is a licensed feature on certain Cores manufactured 
with Q-SYS 7.0 and later. These require activating a license to deploy the plugin to a Core. This is 
indicated with a yellow warning “Licensed Features” shown in the top:  

 
 
Pushing a design requiring licensing to an unlicensed core, will give an error message and the design 
will not be transferred. 
The license is a once per Core, so once the Scripting License is installed, it is possible run as many 
plugins or scripts desired. 
 
Please refer to QSC for further help and info regarding this.   

Getting started 

Installation of the Plugin 

1. Download and install the Q-SYS Designer software version 7 or later from the QSC website.  
2. Install the D Series Lake.qplug by double clicking the file and confirm the installation.  

Add a D Series component to the Schematic [NOT runtime] 

3. After the installation of the D Series Lake.qplug, the Plugin is available from within the Q-SYS 
Designer software under Plugins → User → Lab.gruppen → D Series.  

4. Take the component and place it in the Schematic: 
 

 
 

https://www.qsc.com/systems/products/q-sys-platform/products-peripherals-accessories/software-feature-licenses/
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Connect to an online Amplifier [runtime] 

5. Match the name and model of the Q-SYS Core and do a File → Save to Core and run 
6. Double click on the component to expand the controls. Now while in Runtime, specify the IP 

address of the Online amplifier (the amplifier can be in Standby or On, but must be on the network 
and in the same subnet as the Q-SYS Core) in the IP Address field:   
 
 

 
 
7. If a device can be found on the IP address, the plugin will connect. This is indicated by the “Plugin 

Connected” LED lit Green.  
 

 
 

8. Once connected to a device, all the Read only fields will be populated with data 
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Plugin Overview  

Properties and Pins [NOT runtime] 

Properties  

9. If in runtime, disconnect from Core by doing File → Disconnect. When in design (not runtime) you 
have access to the properties and control pin tabs. In the properties section it is possible to 
change;  
 

a. Polling interval: specifies the time on how often the plugin communicates with the amplifier 
in milliseconds (interval is 400 to 1000 ms).   
The lower settings may work well depending on the size of the system and the 
characteristics of the network. If an amplifier's response is glitchy, unresponsive or 
amplifier control is not reliable, try increasing the polling interval to improve reliability.  
This will however increase the delay in both set and get data.  
 

b. Name: The name that is displayed on the component in the Design. This will not display 
the Frame Label, but it is recommended to name it to the same as the Frame Label.  
 

c. Show Mains: displays Mains Power  
 

d. Show Frame Presets: Will display the section for frame presets.  
 

e. Show Input Routers and Mixers: Will display the section for Input Routers and Mixer 
control 
 

f. Show LoadPilot: Will display the section for LoadPilot  
 
g. Enable Surechecks: if enabled certain potentially “destructive” controls will require 2 

button presses instead of one to prevent accidental clicks 
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Control pins 

10. In the Control Pins section it is possible to enable read/set values of controls from the plugin with 
other external qsys controls.  

 
 

Show Mains 

11. Setting “Show Mains” will add the “Mains” view. This view lets you change the fuse type and 
nominal current. It will also display Voltage and Current. 
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Show Frame Presets 

12. Setting “Show Frame Presets” to Yes will display controls that will let you store or recall up to 100 
presets. 

 
 

Show Input Routers and Mixers 

13. Set “Show Input Routers and Mixers” to Yes will add the “Input Routers and Mixer” view. This view 
adds control of the Input routers as well as the Module Input Mixers. 
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Show Load Pilot 

14. Set “Show LoadPilot” to Yes will add the LoadPilot view. This will present the current configuration 
of LoadPilot and give status of connected load as well as presenting the impedance of the 
connected load.  

 
Note: LoadPilot cannot be enabled from the Q-SYS Plugin. Enabling LoadPilot is done from the 
Lab.gruppen CAFÉ software (available from the Lab.gruppen website). Once LoadPilot is enabled, all 
LoadPilot data is displayed within Q-SYS and also accessible via Control pins. 

 
 
 

 

  

https://www.labgruppen.com/Categories/c/Labgruppen/Downloads
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Component User Interface 

Frame 

 
 

Label Function Description 

A IP Address field Enter the amplifiers IP address 

B Plugin Connected LED Green indicates that an amplifier has been found on the 
IP address entered. Red indicates plugin not connected 
to an online amplifier. Amplifier can be ON or in Standby.  

C Status LED and Display If the LED is green, then there are no faults or warnings  
present and the device is Online on the network. It can 
be either in Standby or On, this is indicated on the 
adjacent Status Display. The display will be green when 
the device is On and there are no faults present (grey 
when the device on online but in Standby).  
If the LED is red, then there are faults or warnings 
present on the amplifier. The Status Display will specify  
the exact fault (what also can be seen in the Lake 
Controller (or on the Front panel as with a PLM+). The 
display will be red if there are faults present as well to 
highlight that there is a present fault.  

D Frame Label Displays the frames label of the amplifier. This is set in 
the Lake Controller 

E Frame ID Displays the Frames ID 

F Firmware Version Displays the current firmware on the amplifier  

G Power On / Standby Indicates the current power state of the amplifier with 
Orange. It is possible to change power state by clicking 
the expected power state.  

H Select Me This will lit the Select LED on the front panel (see 
Operations manual of the product for further 
information). It will also select the amplifier in an online 
Lake Controller.  

I Plugin Version The version of the plugin  

J Dual Redundancy Will indicate in Orange if Dual Redundancy is enabled. 
This can be controlled from the Lake Controller.  

K Link Status Primary and Secondary Ethernet connectors link status. 
If the device have Dual Redundancy disabled, only the 
Prim connector can be lit (the Secondary is disabled also 
if the actual Secondary port is used for Daisy chaining). 
When the Device have Dual Redundancy enabled, the 
Sec will indicate if it has connection.  

L Config Auto, DHCP or Fixed This will indicate the current IP Configuration the device 
has on the Lake interface (Dante can have different). 
This is changed from the Lake Controller.  

M Dante On / Off Will indicate in Orange if Dante is enabled. This can be 
controlled from the Lake Controller. 

A 

B 

C 

D 

E 

F 

G 
H 

I 

J 

K 

L 

M 
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PSU Mains  

 

 

Frame Presets 

 
Label Function Description 

A Recall Select a preset from the dropdown list of the 100 frame 
preset positions from the frame. When a FramePreset 
is selected, press Recall to load the preset.  
It is not possible to recall an “Empty” preset. 
If Surechecks are enabled, it is required to press twice 
within 3 seconds (also applies for pins). If this 
behaviour is unwanted, disable the “Surechecks” 
feature.  

B Quick Store Select FramePreset postion 

C Quick Store The “Quick Store” will overwrite the given FramePreset 
postion selected in (B) with the current settings that the 
device is using.  
It is not possible to Quick Store an “Empty”  

D New Store With New Store it is possible to store the current 
settings that the device is using and manually enter a 
name for the FramePreset and store it on the position 
selected in the Selection Position dropdown (B). A 
name must be give be able to store (do not name 
Empty) 

 

Label Function Description 

A Voltage Meter Mains Voltage Meter 

B Current Meter Mains Current Meter  

C Fuse Type Desired Breaker Emulation Limiter (BEL) Fuse type 
and Actual Fuse Type.  
All models do not have all three fuse types.  
Note: To get correct Actual Fuse type for D10:4L and 
D20:4L firmware 3.36 is required.  

D Nominal Current BEL Desired Nominal current value and Actual current 
setting.  
There will be a difference between the Desired and 
Actual if the specified value is outside the models 
specification.  

A 

B 

C 

D 

A C 

D 

B 
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Input Routers and Mixers 

 

 
 

Label Function Description 

A Force Router Priority Control of the Input Router Priority. Here it is possible 
to go between Auto or Force a specific priority.  
0 = Enable Auto Select Mode 
1 = force Prio 1 
2 = force Prio 2 
3 = force Prio 3 
4 = force Prio 4 

B Input Router Mute  Mutes the router. Blue = unmuted, red = muted 

C Module A,B,C,D Input Mixers Mix Input Router 1-4 from – 100dB to 15dB for any 
Module.  
Note: This is not dynamic, i.e. when using an A/B or 
C/D module where Input Mixer B and/or D is not 
available all 4 will still be displayed, but in that case use 
the Input Mixer for A and/or C.  

 

LoadPilot 

 

 
 

Label Function Description 

A Status LED If the LED is on then there is a fault related to the 
LoadPilot. Look in the respective channel status display 
available in the Power Channels section for further 
details. Frame must be On for LoadPilot to work.  

B Enabled Indicates in Orange if LoadPilot is enabled. This is read 
only indication, LoadPilot can only be enabled from the 
CAFÉ Software (available on the Lab.gruppen 
website).  

C High and Low Tone Readings Displays the current Impedance reading of the High 
and Low tone. Will indicate in red if the impedance is 
outside the thresholds. Frame must be On for LoadPilot 
to work 

D High and Low Tone Min/Max 
Thresholds 

Displays the Min/Max Impedance thresholds of the 
High and Low tone. Frame must be On for LoadPilot to 
work 

 

A 

B 

C 

A 
B 

C D 
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Power Channels 

 

 
 

Label Function Description 

A Unmute All, Mute All and 
Toggle All 

Unmute All will unmute all Power Channel mutes  
Mute All will mute all Power channels  
Toggle All will toggle the mute state of all channels.  

B Temperature LED Yellow if Warning, Red if Fault 

C Status LED and Display If the LED is green, then there are no faults or warnings 
present and the device is Online on the network. It can 
be either in Standby or On, this is indicated on the 
adjacent Status Display. The display will be green 
when the device is On and there are no faults present 
(grey when the device on online but in Standby).  
If the LED is red, then there are faults or warnings 
present on the amplifier. The Status Display will specify 
the exact fault (what also can be seen in the Lake 
Controller (or on the Front panel as with a PLM+). The 
display will be red if there are faults present as well to 
highlight that there is a present fault. 
 
Status Display will be red if there is a fault present on 
the channel and green if there are none. This includes 
Load Pilot faults but excludes Frame faults. Like the 
frame display this display will also be grey if no faults 
are present but the frame is in standby mode.  

D Attenuator Power channel attenuation, from – 100dB to 0dB.  

E Mute Channel Power channel mute, Blue if unmuted, red if muted.  

F V Meter Displays the current Voltage. Frame must be on for this 
to be true. 

G P Meter Power Meter. Frame must be on for this to be true. 

H L Meter ISVPL Limiter Meter. Frame must be on for this to be 
true. 

 

A 

B 

C 

D 

E 

F 

G 

H 
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Support 

 
If assistance is required, please contact Lab.gruppen CARE on care@musictribe.com for further help.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Trademarks & Copyright 

Lab.gruppen and Lake are registered trademarks of Music Tribe Brands Sweden AB.  
PLM, Powered Loudspeaker Management, LM, Loudspeaker Management are trademarks of Music 

Tribe Brands Sweden AB. 
 

QSC® and Q-SYS™ is a trademark or registered trademark of QSC, LLC in the U.S. Patent and 
Trademark Office and other countries. 

 
All other trademarks remain the property of their respective owners. 
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